0
$\begingroup$

By default it seems that AMD gpu's require openCL to use gpu rendering on fedora 35. However, it can be a little tricky to install openCL on fedora 35. I followed the steps from this reddit link, which in the comments seems to work quite well.

As well, I have installed blender from command line via

sudo dnf install blender

At this point when I launch blender, change render to cycles switch device to GPU Compute. The option is faded. So I go to Edit -> Preferences -> System. However, under cycles render devices, the only option available is CUDA:

enter image description here

Any advice would be greatly appreciated. I'm unsure what further steps I should take at this point.

System settings:

             .',;::::;,'.                andrew@fedora 
         .';:cccccccccccc:;,.            ------------- 
      .;cccccccccccccccccccccc;.         OS: Fedora Linux 35 (Workstation Editi 
    .:cccccccccccccccccccccccccc:.       Host: B550 Phantom Gaming 4 
  .;ccccccccccccc;.:dddl:.;ccccccc;.     Kernel: 5.16.20-200.fc35.x86_64 
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.    Uptime: 2 hours, 36 mins 
.:ccccccccccccc;KMMc;cc;xMMc:ccccccc:.   Packages: 2220 (rpm), 7 (flatpak) 
,cccccccccccccc;MMM.;cc;;WW::cccccccc,   Shell: bash 5.1.8 
:cccccccccccccc;MMM.;cccccccccccccccc:   Resolution: 1920x1080 
:ccccccc;oxOOOo;MMM0OOk.;cccccccccccc:   DE: GNOME 41.4 
cccccc:0MMKxdd:;MMMkddc.;cccccccccccc;   WM: Mutter 
ccccc:XM0';cccc;MMM.;cccccccccccccccc'   WM Theme: Adwaita 
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;    Theme: Adwaita [GTK2/3] 
ccccc;0MNc.ccc.xMMd:ccccccccccccccc;     Icons: Adwaita [GTK2/3] 
cccccc;dNMWXXXWM0::cccccccccccccc:,      Terminal: gnome-terminal 
cccccccc;.:odl:.;cccccccccccccc:,.       CPU: AMD Ryzen 7 5800X (16) @ 3.800GHz 
:cccccccccccccccccccccccccccc:'.         GPU: AMD ATI Radeon RX 6600/6600 XT/66 
.:cccccccccccccccccccccc:;,..            Memory: 4174MiB / 15909MiB 
  '::cccccccccccccc::;,.
$\endgroup$

2 Answers 2

2
$\begingroup$

Blender dropped support for OpenCL back in version 3.0 (December 3 2021):

OpenCL rendering support was removed. The combination of the limited Cycles kernel implementation, driver bugs, and stalled OpenCL standard has made maintenance too difficult.

We are working with hardware vendors to bring back GPU rendering support using other APIs.

Reference/Release Notes/3.0/Cycles - Blender Developer Wiki

But Linux support for AMD gpu rendering was brought back in Blender v3.2 (June 8th 2022):

AMD GPU Rendering for Linux has been enabled. Like Windows, this is supported for RDNA and RDNA2 generation discrete graphics cards, which includes Radeon RX 5000 and RX 6000 series, and Radeon Pro W6000 series GPUs.

This currently requires the 22.10 Linux driver from the AMD Radeon repository.

For RDNA1 cards, the drivers have a known bug rendering image textures with certain resolutions, where the width is not a multiple of 128. We recommend using typical texture resolutions like 128, 256, 512, 1024, 2048, 4096 as a workaround, until the driver bug is fixed.

Reference/Release Notes/3.2/Cycles - Blender Developer Wiki

I don't have an extended experience with Blender on Linux other than some centOS and Manjaro all using Nvidia GPUs. But since you do have a Radeon RX 6600 which supports RDNA2, Blender 3.2 should be able to use your GPU, if you get the drivers right.

$\endgroup$
1
$\begingroup$

Unfortunately Blender dropped support for OpenCL for some reason.

Now Bender only works with HIP, CUDA or OptiX. All of them only works with proprietary drivers, and HIP only works on RDNA2 gpus.

You just can't use any other AMD gpu on Blender 3

$\endgroup$
1
  • $\begingroup$ "For some reason"? $\endgroup$
    – L0Lock
    Aug 10, 2022 at 20:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .