0
$\begingroup$

I'm making a scene for commercial curtains and I thought of using Godrays but for some reason it doesn't show up as I want and also I feel like something is lacking from my Scene

I'll attach the basic file for Godrays settings

First Shot

Second Shot

$\endgroup$
2
  • $\begingroup$ The scene seems to me too bright to generate such effect (also in reality). Godrays are result of light ray hitting particles (dust, humidity) in a dark envi. So probably consider to use some post-pro technique. $\endgroup$
    – vklidu
    Commented Apr 23, 2022 at 11:59
  • $\begingroup$ @vklidu thanks man, Almost forgot how it worked irl, I'll surely render it in dark env and then compose it $\endgroup$
    – Ace
    Commented Apr 23, 2022 at 17:40

3 Answers 3

2
$\begingroup$

Compositor – Sun Beams

Similar effect can be faked by compositor. Here I used alpha (when rendered without background)...

enter image description here

... as the source for Sun Beams node

enter image description here

enter image description here

enter image description here

A bit difficult for complex scene with a lot of objects in between beams ... but could be useful in some cases.

$\endgroup$
2
$\begingroup$

The scene seems to me too bright to generate such effect (also in reality). Godrays are result of light ray hitting particles (dust, humidity) in a dark envi make the light visible, that is hard in such a shiny room.

Volume Scatter

In this example I increased Sun Strength to 100, Volume Scatter to 0.1 and all materials are set completely black (disconnected Output nodes) to get this result.

What helps to make it sharper is under Render Properties > Light Paths > Max Bounces > Volume set to zero.

enter image description here

So probably consider to use some post-pro technique.
Like render scene without volumetric object ...

enter image description here

... and Volume separately ...

enter image description here

... and mix it, but still (even contrasted) it doesn't seem to look natural too much.

enter image description here


Side Notes:
Render Properties > Light Paths > Max Bounces > Volume set with higher value doesn't mean sharper, because bouncing light ray is more spreader across a scene. That is correct in reality, but you want to avoid that. Here is volume object covering whole room to see effect better.

enter image description here

What I expected that should make it sharper is change Render Properties > Volumes > Step Rate to something lower like 0.01, but when I tried it. for Viewport there wasn't difference, hm.

$\endgroup$
2
  • $\begingroup$ A question tho, why did you changed volume bounce to 0, I thought the higher the number the clearer it is and setting to 0 would mean it'd completely avoid it, And Thanks a lot for the info on Scatter and sun settings. $\endgroup$
    – Ace
    Commented Apr 23, 2022 at 17:44
  • 1
    $\begingroup$ See edit ... notes $\endgroup$
    – vklidu
    Commented Apr 23, 2022 at 18:29
1
$\begingroup$

In order to use godrays, place a cube around your whole scene. Make the cube have a volume scatter node in its material slot, and change the density to around .1. If you have a directional light in your scene (spotlight, area light, etc.) You will be able to see godrays. More info here: How to do volumetric lighting for a forest scene?

(They said in the link to change the world's volume, but that won't work if you have an HDRi)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .