I don't know if this is intended on Blender 3.1.2, but I am working on a model and when I try to hide with the sub-surf modifier on it doesn't hide the surface. The vertices no longer select-able but still visible in the view port. The vertices under the model surface are select-able but the body doesn't hide until I turn the sub-surf modifier off with the View port off button in the modifiers. The vertices I am working on were created off a surface using Duplicate but are not their own Object. I was trying to keep the sub-surf modifier on while working on the duplicated area. Pictures and replication as follows:

enter image description here Sub-surf mod on, nothing hidden

enter image description here Sub-surf mod on, cube hidden and still visible? but only duplicated face select-able

enter image description here Sub-surf mod off in view port, cube still hidden no longer visible but face loses modifier

Replication steps:

  1. New project cube
  2. Enter Edit Mode
  3. Duplicate (Shift+D) top face of cube of cube and place a small distance over cube
  4. Apply the subdivision-surface modifier
  5. Verify modifier boxes are selected (cage, viewport, etc)
  6. Select all faces of cube and Hide (H)
  7. The cube is still visible and no vertices/edges/faces are select-able, except the face that was duplicated.
  8. Click the View port button on the sub-surf modifier and the cube disappears but now the duplicated face no longer has the modifier.

Is this a bug or as designed?

  • $\begingroup$ This appears to be a bug. Please report it on Blender's bug tracker or let me know and I'll create a ticket for you. $\endgroup$
    – Robert Gützkow
    Apr 21, 2022 at 9:20
  • $\begingroup$ Yes please do. This is an issue with GPU sub-surf turned on in preferences. $\endgroup$
    – Solorn
    Apr 21, 2022 at 14:46
  • $\begingroup$ I was informed by Philipp Oeser that this was already report in developer.blender.org/T96080 $\endgroup$
    – Robert Gützkow
    Apr 22, 2022 at 10:11
  • $\begingroup$ Ok, thank you again for reporting the bug. Looks like it’s been elevated to get solved now. $\endgroup$
    – Solorn
    Apr 22, 2022 at 19:51

1 Answer 1


I have tried doing exactly the steps you provided. When I tried doing step 6 (selecting the face of the cube and pressing H to hide it), this is where our outputs differ. In my case, the cube is no longer visible. This led me to think that our settings might be different so I tweaked here and there and found that your GPU subdivision might be turned on. You can turn it off by:

edit > preferences > viewport > Subdivision > Uncheck GPU subdivision

This might do the trick.

I can't explain why the GPU subdivision does this because I don't know anything about the backend side of blender but turning it off might give you the output you expect.

Kind Regards.

  • $\begingroup$ Yes that was the issue. Turning the GPU subdivision off allows the cube to hide now. $\endgroup$
    – Solorn
    Apr 21, 2022 at 14:45

Not the answer you're looking for? Browse other questions tagged .