1
$\begingroup$

This is what my baked AO texture looks like (not in all places -- for most faces it looks fine):

enter image description here

What is the cause of this? What can I do to resolve it? I do not have any overlapping UVs and my mesh is manifold.

Here is the mesh if you would like to take a look: http://pasteall.org/blend/34604

Thank you all for your help!

$\endgroup$
  • 5
    $\begingroup$ It seems there are some overlapped faces in your mesh. A .blend file would be very helpful. $\endgroup$ – Leon Cheung Feb 22 '15 at 5:46
  • 1
    $\begingroup$ Are you using a version of Blender from buildbot? Is this Cycles or Blender Internal? You might want to load the .blend file to Pasteall.org and paste the link here. $\endgroup$ – MarcClintDion Feb 22 '15 at 7:14
  • $\begingroup$ I tried using the "select non-manifold" option (Ctrl+Alt+Shift+M) and nothing came up. So I don't think there are any overlapping faces. Here is the .blend if you want to take a look: pasteall.org/blend/34604 $\endgroup$ – Flafla2 Feb 22 '15 at 18:18
  • 1
    $\begingroup$ After checking the file, the problem was caused by some hidden objects, which is something about overlapping as well. To fix it, you can Alt H to show them all, then delete them or move to other invisible scene. $\endgroup$ – Leon Cheung Feb 22 '15 at 19:28
  • $\begingroup$ Ah, ok. I didn't realize that other hidden objects affect the AO bake. Thanks. $\endgroup$ – Flafla2 Feb 22 '15 at 20:54
1
$\begingroup$

The problem was caused by other objects overlapping the object that I wanted to bake. When modelling I used the boolean modifier with some other objects and hid the old objects after applying it. By deleting the old objects the bake worked perfectly.

Thanks to Leon Cheung and MarcClintDion for their help!

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.