2
$\begingroup$

I started working on freelance job, and all customers saying my mesh rotation is ruined, I applyed all transforms, playing with fbx export settings didnt help at all, I tried different version of Blender didn't help .

When I export fbx from blender with reset transform values, and import back in Blender I get this weird -0.000009d on X axis. Applying transforms didn't help either.

enter image description here

$\endgroup$

1 Answer 1

2
$\begingroup$

Choose Apply Transform when export FBX

enter image description here

Why this happens?

If you change the export settings to use Z-up, Y-forward and re-import that, there is no problem. Otherwise it will rotate the mesh. The coordinate is stored with floating point and when you rotate it you get a floating point precision issue.

If you rotate x-axis 180 degrees and rotate x-axis -180 in viewport, you will see the same problem. (0d --> -0.000004d).

Why not use more accurate floating point system? Because of performance problems, it would for example take more time to render.

With other software it would have similar problems if using floating point.

$\endgroup$
1
  • $\begingroup$ Thank you so much,I changed to z up and y forward and it workded. Your a Lifesaver. $\endgroup$
    – Artsate
    Commented Apr 19, 2022 at 19:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .