1
$\begingroup$

I'm new to blender and I'm making a simple rigged character but whenever I try to join my clothing mesh to the armature, the mesh becomes deformed.enter image description here

The armature still moves the mesh in pose mode, but I don't know how to fix this mesh deformity. Help is much appreciated.

$\endgroup$
7
  • $\begingroup$ first apply the scale and rotation of the cloth and armature, also make sure that the normals are correctly flipped, then parent again. If it still doesn't work please share your file: pasteall.org/blend $\endgroup$
    – moonboots
    Apr 19, 2022 at 6:37
  • $\begingroup$ @moonboots sry, could you explain what you mean? I didn't get what you meant. $\endgroup$
    – Bhanujeet
    Apr 19, 2022 at 8:29
  • $\begingroup$ Please provide the file it will be easier, upload the file then copy paste the URL it will generate: pasteall.org/blend $\endgroup$
    – moonboots
    Apr 19, 2022 at 8:33
  • $\begingroup$ The file exceeds the 24mb capacity of pasteall. Is there any other way I can send it to you? $\endgroup$
    – Bhanujeet
    Apr 19, 2022 at 14:33
  • $\begingroup$ send it to yourself with wetransfer and share the link here $\endgroup$
    – moonboots
    Apr 19, 2022 at 17:03

1 Answer 1

1
$\begingroup$

You were trying to parent your costume while your armature was not in rest pose.

Apply the scale of your objects and armature, also apply the rotation of your costume. Bring back your armature to its reset pose in Pose mode with AltG, AltR, AltS. Once done, put the costume at the same position as the armature. As you'll see there's still a problem, your armature default pose it a T pose, not your costume, so you need to align the costume shape:

enter image description here

You could do it this way: Duplicate the armature, in Edit mode align the bones with the costume shape, parent the costume to this second armature, move the armature to a T pose, apply the armature, now your costume has a T pose as well, you can parent it to the first armature.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .