0
$\begingroup$

Every time I have tried to enable the Cube Surfer addon but this error message comes up. FYI I have the correct versions of everything.

I have had this problem with some other add ons as well. Sometimes it's when I have tried to click a button in an addon (after 'successfully' installing) enter image description here

$\endgroup$
4
$\begingroup$

Technically this is off-topic for blender.stackexchange but I expect several people will be interested and have trouble getting this addon working so I will add this info here.

Cube surfer is written in cython not python. The cython project is a kind of hybrid between C code and python code. You need to convert the .pyx file in CubeSurfer to a c file then compile it into a shared library. You will need to install cython and a compiler if you don't have them already.

There is a setup64.py to build it included with CubeSurfer, it is only setup for windows, for other platforms you will need to make some changes.

If you have trouble building this you will need to ask for help on irc or stack.overflow or the CubeSurfer developer

It could be possible that builders may offer this addon pre-compiled with graphicall builds - there don't appear to be any yet.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.