0
$\begingroup$

I made a custom Sonic model, with a custom rig, and for some reason, even after lowering the poly count, or removing doubles, automatic weights keeps failing. I'm not sure what else I can do. If anyone has some tips, please share.

File:https://www.mediafire.com/file/mf8ujfm58vxo8o3/Modern_Sonic_Model_Rigging_Proccess.blend/file

$\endgroup$
3
  • $\begingroup$ Automatic Weights works for me, it will need a bit of corrections though, what do you mean when you say that it fails, is there a message? Nothing happens when you move the armature? zupimages.net/up/22/15/kyo1.gif $\endgroup$
    – moonboots
    Apr 16, 2022 at 17:56
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Apr 16, 2022 at 22:16
  • $\begingroup$ I get the message: Heat Weighting: Failed to find solution for one or more bones. Sorry for late response, I had work. $\endgroup$ Apr 17, 2022 at 1:20

1 Answer 1

0
$\begingroup$

I didn't have any problem getting your mesh to bind to the armature by:

  1. Enter Object Mode
  2. Select Mesh, SHIFT+select rig
  3. Type CTRL+P
  4. Select "Parent with Automatic Weights"

Here is a link to the rigged mesh: https://www.mediafire.com/file/0j5plr4n1b2xb0j/Modern_Sonic_Model_Rigging_Proccess.blend/file

enter image description here

$\endgroup$
1
  • $\begingroup$ That’s weird that it worked for you. I was using blender 2.79. Is the AI that applies the weights is smarter on newer versions? $\endgroup$ Apr 17, 2022 at 1:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .