2
$\begingroup$

When I want to render an image so that the floor is transparent and the object with the shadow is visible, only the shadow remains. I used to do that and it worked, but now it doesn't. I had to kick something, I just can't find the reason. Can anyone help? Lenter image description hereink https://drive.google.com/file/d/1KAt7kp4YY-LYHSBLgi1GEBDAU9rxzPfw/view?usp=sharing[2]][2]

enter image description here

$\endgroup$

1 Answer 1

4
$\begingroup$

In the file you provided:

  • The Render Engine was set to EEVEE. I changed that to Cycles and enabled GPU compute.
  • Render Properties → Film → Transparent was not enabled. I enabled that.
  • The plane did not have Object Properties → Visibility → Shadow Catcher enabled. I enabled that.

and the biggest problem was:

  • The Cube did not have Object Properties → Visibility → Ray Visibility → Camera set. I enabled that.

The last was the reason why the object wasn't showing up in the Cycles Render

with those changes, I get this render:

rendered image

Is that what you are looking for?

$\endgroup$
2
  • 1
    $\begingroup$ Thank you very much, everything works. I did not think too well and hence the error. $\endgroup$
    – Janusz
    Apr 16, 2022 at 15:35
  • 1
    $\begingroup$ @Janusz you are very welcome. Blender's render engines have a lot of settings and sometimes it just takes a bit of work to make sure you have them all set properly. $\endgroup$ Apr 16, 2022 at 18:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .