0
$\begingroup$

I have followed several tutorials on the Youtube.

This is the cloth I made, I double check there is no duplicated vertex left in the mesh.

enter image description here

I also applied the scale and rotation for both cloth and human body.

enter image description here enter image description here

This is the result occurred in the last period.

enter image description here

I have tried to add subdivisions and still get a wired result

enter image description here

I have no idea about how to fix this issue.

$\endgroup$
4
  • $\begingroup$ Here is the link to download this blender file drive.google.com/file/d/1t-RIXcjIPi4ujR8g3hxExlUOrZnInZfN/… $\endgroup$
    – Matrix-X
    Commented Apr 16, 2022 at 5:41
  • $\begingroup$ The back of the cloth template has flipped normals. Select the back part of the mesh and flip it with Alt+N in Edit mode. Also, don't apply the Subdivision modifier. You have added edges before you added the modifier and there are now edges missing and the existing edges are subdivided. This will create holes at the seams. $\endgroup$
    – Blunder
    Commented Apr 17, 2022 at 15:34
  • $\begingroup$ I have tried doing the flip normals, the back of cloth works. Thanks, the rest issue as you mentioned about the edges, I will try to redo the edges according the tutorial again! Thank you! $\endgroup$
    – Matrix-X
    Commented Apr 18, 2022 at 16:46
  • $\begingroup$ What does it look like in the tutorial? Blender has a bug (or feature, I don't know) It does not remove the threads nor does it merge the vertices of the islands. If you want to see the seams with a Solidify modifier you need to clean up the mesh a bit. $\endgroup$
    – Blunder
    Commented Apr 22, 2022 at 13:15

2 Answers 2

0
$\begingroup$

Here is a test with the following changes:

  • turned off Self-Collision as suggested by BlenderMaster15
  • lowered Collision > Distance to 5 mm to get the fabric is closer to the body
  • lowered the Collision > Softbody & Cloth > Thickness Outer value to 0.001 also to get the fabric is closer to the body
  • use Elastic Deformation brush in Sculpt mode and made the upper parts of the sleeves a bit wider. Rotate the end of the sleeves a bit (Pose brush) and straightened the back of the neck.
  • flipped the faces of the back
  • added more threads

sewing prepare

The result after 30 frames:

sewing result

There are still some glitches and the mesh islands are not connected. But this can be changed manually (or with a script) after the Cloth modifier has been applied.

$\endgroup$
1
  • $\begingroup$ Thank you for your test! $\endgroup$
    – Matrix-X
    Commented Apr 25, 2022 at 9:22
0
$\begingroup$

Fixed! Turn off "Self-Collisons" in the shirt's cloth modifier.

$\endgroup$
1
  • $\begingroup$ Thank you for your help! I have turned off the "Self-Collisons" trigger and it seems that the cloth is not weird like before, But still cannot seems like the same as the effect of tutorial. $\endgroup$
    – Matrix-X
    Commented Apr 17, 2022 at 5:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .