Desired Goal

  • Use the offset in the Fluid Simulation Panel to read in 1 or more frames for the 3D View Window. Reuse the mesh data created from a fluid simulation. A Read Only status is desired.

Current Flawed State

  • The offset has worked periodically and is under suicide watch. That is an [update]. When the offset is changed I may see nothing even when going to a different frame. The default zero value works. Sometimes the cache mesh is deleted unexpectedly, apparently I know the magical sorcery to do so.

Actions Taken Thus Far

  • File Import
    • Use [.obj] file format for mesh creation in the cache panel.
    • Less preferable. Export the data to .obj format using the export menu choice.
    • Import the .obj file format data created above from the file menu. This converts a single frame .obj file to a mesh. This has more Read Only behavior. At the moment this has some value.
  • Duplicate a fluid domain in the same scene. This does not provide read only capability. Append library possible.

An offset number exists in the UI for fluid simulation.. I have not used it successfully. I do not see a UI for using a driver with this data. Other items nearby do have the [add driver] menu choice.

I want to use a portion of a completed fluid simulation. Files have been copied and renamed.

Is there a way to tell Blender to [Read Only] the mesh data? Never delete any data files.

The User can copy a fluid domain and repeat the display.


1 Answer 1


From the Documentation:

Offset Frame offset that is used when loading the simulation from the cache. It is not considered when baking the simulation, only when loading it.

So, it seems like offset is for the case when you have already baked a simulation, the total bake frames exceed the shot length and you want to offset the start frame when the bake is being read and displayed.

Like if you wanted a 500 frame simulation to start 1 second later in a 24fps scene, you would enter "24" into this value.

Additionally, you must set the Type to Modular and rebake in order to use this setting correctly.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .