1
$\begingroup$

I have a problem with Blender when exporting my model to Collada. I created a simple chest after following a tutorial on Youtube.

I order to animate the opening of the top-part, I've added a single bone and set the parent's object with an armature deform with empty groups. After that, I selected the corresponding vertices of the bone's vertex groups and assigned them.

Finally, in pose mode, added the rotation & location keyframes.

The animation in Blender is what I wanted, but after exporting as a Collada file, my model seems to "turn" around an other axis (with the native viewer of MacOS at least...). Despite checking different options, I wasn't able to find where the problem is.

Animation in Blender On Blender Collada model Collada model

Could you help me figuring what the problem is ? Thanks !

EDIT : If "Use Blender Profile" wasn't checked before the collada export, when I try to import the file again in Blender I get this :

enter image description here

$\endgroup$
5
  • $\begingroup$ Does it need to be exported as a .dae? Have you tried an .fbx export? $\endgroup$ Apr 14, 2022 at 16:01
  • $\begingroup$ Yes, for some reason I really need to export in dae format (I'm loading it in C++, and the collada loader is fully implemented). I saw that there was the possibility of exporting to fbx and then dae through Cheetah3D. But considering the price of the tool, meh... $\endgroup$
    – Weezo
    Apr 14, 2022 at 16:16
  • $\begingroup$ I exported it as a usdc and it worked fine. However exporting it as a dae didn't work, like you said. $\endgroup$ Apr 14, 2022 at 16:56
  • 1
    $\begingroup$ It's always a good practice if you have a root bone, parent of all bones which never moves. $\endgroup$
    – FFeller
    Apr 14, 2022 at 17:53
  • $\begingroup$ I just added a fixed root bone. After the export, the main box doesn't move but the lid of the chest continues to move oddly :/ $\endgroup$
    – Weezo
    Apr 14, 2022 at 18:27

2 Answers 2

1
$\begingroup$

Finally found the solution, here's my steps if someone get stuck with the same problem.

Just before exporting the model to .dae, in Pose mode, I had to select the bones (I've added a static root bone since my first post) and reset the rotation, translation and scale by pressing respectively Option+R, Option+T and Option+S (ALT+R, ALT+T, ALT+S on Windows).

After that, in Object Mode, I selected the mesh, and applied all the transforms ("Object" menu > Apply > All Transforms). Did the same with the armature.

After the export, everything seems to be ok !

$\endgroup$
0
$\begingroup$

I don't whether this helps your in your case, but if i export to .dae with

enter image description here

...export to SL checked

and

enter image description here

transform : decomposed, i could successfully import it to Blender again and the animation worked.

$\endgroup$
2
  • $\begingroup$ Thanks for the answer. Unfortunately it doesn't solve my problem here as I can import my previous dae file into blender with the correct animations. It's when viewing it in the macos viewer that it doesn't work (same result after loading it in c++). In addition, with your solution, nothing is displayed in the macos viewer :/ $\endgroup$
    – Weezo
    Apr 14, 2022 at 19:26
  • $\begingroup$ EDIT: "Nothing is displayed": in fact there's the model but I had to rotate the viewer. In both cases, I can import the files in blender only if "Use Blender Profile" was checked before exporting. $\endgroup$
    – Weezo
    Apr 14, 2022 at 20:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .