1
$\begingroup$

I have a character which is one single object that has multiple materials assigned to it. Each material has a few texture maps corresponding to a specific Vertex group. Now here's the question:

When I select all vertices in 3D Viewport to check their texture in UV Editor, many of the vertices are out of the area in which the texture is supposed to be. Here is a photo: enter image description here

Everything is fine and all the textures are correctly shown on the object. But I want to know why? and how to achieve the similar result?

$\endgroup$
5
  • 2
    $\begingroup$ Hi :). It works because textures are tiled by default - so UV islands can be placed outside the UV bounds to keep them organized. $\endgroup$ Apr 9, 2022 at 10:36
  • $\begingroup$ So the textures are there but I can't see them. Is it possible to resize the UV bounds? Or I just have to resize my texture size? $\endgroup$ Apr 9, 2022 at 10:44
  • $\begingroup$ Not sure what you mean :) You can show the repeated image in the UV editor, to properly align meshes outside the UV bounds :). $\endgroup$ Apr 9, 2022 at 10:48
  • 1
    $\begingroup$ to see the repeated image, as Jachym says, in the UV Editor, open the N panel > View > Display > enable the Repeat Image option $\endgroup$
    – moonboots
    Apr 9, 2022 at 10:52
  • $\begingroup$ Thanks Moonboots this is what I was looking for. $\endgroup$ Apr 9, 2022 at 11:02

1 Answer 1

2
$\begingroup$

I decided to answer my question so if other's had the same question could find the answer more easily. As moonboost pointed, open the N panel > View > Display > enable the Repeat Image option this way you can take advantage of the tiled textures to map UVs accordingly.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .