8
$\begingroup$

I'm rendering a crystal like object and another with a single planar texture, the first one needs to be rendered at high sampling and the second one doesnt, yet i need to render them both together, is it possible to give an object a number/quantity for sampling while for the others another number/quantity?

$\endgroup$
  • $\begingroup$ I have one that I know will work, I will post an answer ASAP $\endgroup$ – VRM Feb 17 '15 at 21:11
5
$\begingroup$

This can be done using Render Layers. First, make sure your two objects are on seperate layers, but both are selected in the viewport. Now go to the Render Layers tab and press the + button:

Add Render Layer

Name them HighSample and LowSample, and make the Layer attribute reflect which objects you want to render at higher or lower sample rates.

Important: do not use the Exclude option! This will make the effect completely impossible.

Now that you have your render layers set up, you can change a handy little Samples value to override the set number of samples in the Render tab. If you render now, you will notice it renders two images, with separate objects. All you need to do now is be sure you have Transparent enabled in the Render settings and do a little simple compositing:

Compositing Nodes

Render Result:

Render Result

The plane has samples set to 10, and the flat shaded Icosphere used 100 samples.

$\endgroup$
11
$\begingroup$
  1. Put both objects on separate render layers

  2. Override the number of samples:

    enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.