5
$\begingroup$

I currently have a simple scene in blender consisting of a particle emitter with thin rectangular prisms as particles. They have a pretty fast speed, and it's causing some terrible looking artifacts in the final renders.

I've tried this with standard vector blur with compositing nodes in blender:

enter image description here

And I've tried this with the basic motion blur option available in Cycles: enter image description here

This looks really great as a still image, but as soon as I actually go in and press the "animate" button instead of still render, it starts to fall apart.

enter image description here

And in my current revision, the Motion blur setting makes frames horribly messy and doesn't seem to know where the object is going. Blurs are curved instead of linear like in the still image.

enter image description here

I've never had a problem like this before where the animation view looked different than the still image view. What's going on, and how can I fix it?

Here's a link to my blend file.

EDIT: Fixed by nik10110 Here's a gif: enter image description here

$\endgroup$
  • $\begingroup$ This might be a bug... $\endgroup$ – GiantCowFilms Feb 17 '15 at 17:30
  • $\begingroup$ Any idea on how to get around it? I'm trying to avoid sampled motion blur, but I have a feeling I'm going to need to use it. $\endgroup$ – Alexander Lozada Feb 17 '15 at 17:31
5
$\begingroup$

Your particles seem to be rotating a tad in-between the frames (bug in particles?)

The solution is to turn on rotation for the particle system, and leave the values at 0.

particle rotation on for stable particles

As for having different results between render and animate, try baking the particle system.

baking_particles

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.