1
$\begingroup$

I am facing a problem where I am trying to make the car follow the path made with Bezier Curve, it is rigged, and it was scaled up to fit the size of the road. The proper model is here:

car model (https://gyazo.com/a8aab00c9c7fdf13680043bcb237623f)

After adding the constraint to the model, I cannot rotate the model anymore as it transforms really weirdly, although I need it to make it drift. Photo below:

distorted car model (https://gyazo.com/3af59e3197d97dc3e4ab3598bcdef134)

I am trying to follow the video "How to do a car animation in BLENDER! (Advanced)" by WilliamLandgren

Here is my .blend file (the car model is pretty huge): https://drive.google.com/file/d/1OLVpbHA_NtrG12Ee76xVyl7v1hkFEKsA/view?usp=sharing

Any help would be appreciated :)

$\endgroup$
4
  • $\begingroup$ hello could you please share your file (only the important items)? $\endgroup$
    – moonboots
    Commented Apr 1, 2022 at 7:00
  • $\begingroup$ Hey, I only left the car in the .blend file and the drive path. The car seems to be around 150MB, so I had to upload it to Google Drive. By the way, also the tires rotate weirdly; they look sloppy while rotating. Could it be the model? I love the car; maybe I could just change the tires if the rotation problem gets solved. $\endgroup$
    – RondoWz
    Commented Apr 1, 2022 at 9:36
  • $\begingroup$ are you sure you're sharing the good file? I can't see the deformed car, at what frame is it? $\endgroup$
    – moonboots
    Commented Apr 1, 2022 at 9:53
  • $\begingroup$ The point is, if the car follows the path then I want to rotate it so it looks like it drifts. I haven't keyframed the rotation yet, but you can try rotating on different axises $\endgroup$
    – RondoWz
    Commented Apr 1, 2022 at 15:00

1 Answer 1

1
$\begingroup$

Your curve is squished:

enter image description here

Select the curve then press Ctrl + AScale

Scale should be equal in all directions:

enter image description here

$\endgroup$
3
  • $\begingroup$ For some reason, I can not see the curve in my scene anymore, I can select it under collections, but the Apply Scale doesn't apply to it. It is enabled in the viewport. $\endgroup$
    – RondoWz
    Commented Apr 1, 2022 at 15:46
  • $\begingroup$ It's because you have endered in local mode, press Num "/" $\endgroup$
    – Crantisz
    Commented Apr 1, 2022 at 16:30
  • $\begingroup$ Thank you, got it solved! $\endgroup$
    – RondoWz
    Commented Apr 1, 2022 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .