1
$\begingroup$

I have had an amazing problem about IK and FK mode. Snap is used to copy the animation from IK to FK or from FK to IK. So, normally, When i do an animation using IK and FK mode, I can finally run it in each mode without loss for any motion. but in http://www.pasteall.org/blend/34672 , I remark that when i run it in IK mode for all bones, the hands did not move. What is the problem?

$\endgroup$
  • $\begingroup$ Not quite sure what type of panel you are using. If you're only asking about how to do the animation(and not whether you're using the panel wrong), you can keyframe(press "I") and select "Visual loc/rot/scale". This will keyframe the position the bone is in, regardless of parenting/IK-solver/etc. $\endgroup$ – Einar Feb 17 '15 at 15:59
  • 1
    $\begingroup$ So in IK-mode, keyframe visual LocRotScale, then change to FK. Bones will stay put. $\endgroup$ – Einar Feb 17 '15 at 16:00
  • $\begingroup$ @NaioaiStudios, I edited my example. $\endgroup$ – BetterEnglish Feb 18 '15 at 19:45
2
$\begingroup$

When editing the walkcycle action alone (file has the same issue as in this question) you haven't properly keyframed the IK-arms. In the timeline set the VisualLocRot as keying-set:

enter image description here

Go to the keyframes in IK mode and place the hands where you want them to be. Thereafter you can switch seamlessly between IK and FK mode. enter image description here

$\endgroup$
0
$\begingroup$

Sandler answered your question on point. Blender cannot "automatically" set key frames for everything. You simply need to set one key frame (try pressing keyboard key "I" over the bar that adjusts the ik/DK influence). After that, blender should record changes to that value.

$\endgroup$
-1
$\begingroup$

A rig that has both IK and FK controls will have two separate bones that may control your character, the setting to switch between each determines which one is in control at any given time. You also need to keyframe these settings to ensure the right bones are in control.

You don't appear to have any keyframes on the IK/FK settings.

To keyframe a value you can right click and choose Insert Keyframe or press I while the cursor is over the value. You may want to change the interpolation to constant in the graph editor or set keyframes on two adjacent frames to switch between the two.

$\endgroup$
  • $\begingroup$ But i used the automatic key frame, so why did I need to add key frame. $\endgroup$ – BetterEnglish Feb 19 '15 at 7:12
  • $\begingroup$ You will need to manually add at least one keyframe to the IK/FK value (for each arm/leg) after that it will record changes as you make them. $\endgroup$ – sambler Feb 19 '15 at 7:39
  • $\begingroup$ Can you explain me more why I need to do that because I understand by clicking on the red button frames are saved automatically. $\endgroup$ – BetterEnglish Feb 19 '15 at 14:59
  • $\begingroup$ as expected your solution did not give any new results $\endgroup$ – BetterEnglish Feb 19 '15 at 16:28
  • $\begingroup$ It is a big problem $\endgroup$ – BetterEnglish Feb 19 '15 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.