1
$\begingroup$

I'm making a simple sweater for my model. I've added normal map node, set texture to "non-color", baked normal map from Multries without any polygon artifacts and I got this:

Shade Smooth is On, Auto Smooth is off. Non-Color was set before baking as well.

It does not depends on this saturated pink-green colors, polygons appear on a whole mesh. I tried to make NM in a new file but it has the same problem.

I used Blender 3.0, 3.1 and even 2.93. Also checked on my laptop. I saw that strong lightning can hide it but it doesn't solve the problem anyway. Hope someone knows how to get rid of this.

$\endgroup$
8
  • $\begingroup$ I can't see any problems in the normal map and since I don't see any other settings apart from the material, it's hard to guess what other reasons there could be. It would be best to provide the blend file. Or check the Object Data Properties tab for Geometry Data. If there is a button "Clear Custom Split Normals Data", then click it. $\endgroup$ Commented Mar 30, 2022 at 11:26
  • $\begingroup$ Attached. But, as I said, it also happens in default files (on different PCs), although everything was good until this moment. $\endgroup$
    – jghkhgjlhj
    Commented Mar 30, 2022 at 12:45
  • $\begingroup$ Whose kind of areas indicates that you really had some issues with baking. Whey are too bright for typical normal map ![enter image description here](i.sstatic.net/OuuDM.png) $\endgroup$
    – Crantisz
    Commented Mar 30, 2022 at 13:47
  • $\begingroup$ This could be a reason. I'm not an expert in normal maps, but if they are way too bright and that in combination with a Strength of 5 in the Normal Map node (screenshot says 1, but the file I downloaded has 5), this might be an issue. But I cannot really test anything because the normal map is not packed into the file. $\endgroup$ Commented Mar 30, 2022 at 14:44
  • $\begingroup$ @GordonBrinkmann yes, but it is in post as image $\endgroup$
    – Crantisz
    Commented Mar 30, 2022 at 14:48

1 Answer 1

0
$\begingroup$

So in my case the problem was a blender version. I downloaded 2.83.14 (I cleaned all the previous settings in AppData\Roaming\Blender Foundation\Blender\2.83 before), added subdivided cube and baked simple normal map - everything looks nice. If I open the same file in the latest version it shows polygons again:

If someone has such a problem I suggest to download another version of blender. But I also noticed that you need to create mesh in this version instead of the newest one, otherwise it will have flat shading. But I still don't think it is a right solution. (resetting blender >2.93 also didn't changed anything)

$\endgroup$
1
  • $\begingroup$ There is definitely something wrong, and probably with the scene itself considering how exporting the model I.E. as fbx magically "fixes" the issue. Do you happen to have started working on 3.x and then went on an older Blender version? $\endgroup$
    – Lauloque
    Commented Mar 31, 2022 at 13:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .