I'm working on a big scene. From one point I noticed a drastic change in the viewport performance. To find out what was draining FPS I tried to exclude every collection from the layer and all the fancy staff from the viewport, ending with still low FPS, and really nothing happening. enter image description here

Where can I look to solve this problem?

EDIT. Here is how the file is organized: enter image description here

The scenes are linked duplicate, each one with just one render layer. If I try to deactivate ALL the collection from ALL the layer nothing changes. (Also tried to turn off the world shading setting)

What I'm wondering the most is:

Witch is the workflow to debug low FPS situation? Am I correct assuming that the disabled collection shouldn't be evaluated?

  • $\begingroup$ search here for performance, viewport, fps -> there are lot of answers to this theme. What helps is: reduce subdivision modifier level for viewport, reduce objects, reduce resolution (in simulations)...and much more $\endgroup$
    – Chris
    Mar 27, 2022 at 11:40
  • $\begingroup$ I saw them but it's not my case. As you can see there are no vertices in the viewport... $\endgroup$
    – Lucho
    Mar 27, 2022 at 11:48
  • $\begingroup$ to be honest...i don't see a lot because you didn't provide really useful information. We don't know whether you have more scenes than 1, we don't see whether you have more view layers...you didn't gave us any useful information to be honest. So pls provide blendfile or ALL needed informations. thanks. $\endgroup$
    – Chris
    Mar 27, 2022 at 11:56
  • $\begingroup$ I made an edit, let me know if some other important is missing. $\endgroup$
    – Lucho
    Mar 27, 2022 at 12:20
  • $\begingroup$ Do you have any simulations going on like physics, fluids, smoke…? If yes, what settings have you there? $\endgroup$
    – Chris
    Mar 27, 2022 at 12:26

1 Answer 1


This appears to be a known issue with disabled collections not neccessarily disabling their objects: #100754

There is a suboptimal workaround:

You can actually hide objects under a collection altogether with Shift + Left Click on the eye icon beside the collection. This action is also available in right click menu: Visibility > Hide All Inside and Show All Inside.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .