22
$\begingroup$

I have a problem. I am going to make a minecraft animation in blender. But when I put a minecraft texture on a 3d cube that is 16x16x16 it is very low resolution is there a way to get the texture in a better resolution or is there a way to make blender make the texture better?

I hope you have an answer. Thanks in advance

$\endgroup$
  • 1
    $\begingroup$ Related: minecraftforum.net/topic/… $\endgroup$ – wchargin Aug 26 '13 at 17:29
  • 1
    $\begingroup$ You go to user prefrences and disable mipmapping. $\endgroup$ – Melvin Sep 14 '15 at 2:27
26
$\begingroup$

In addition to scaling the textures up in an image editor with pixel interpolation disabled, (as mentioned by Gunslinger)
Another method is to disable pixel interpolation right in Blender and save memory, and as already mentioned by Krivar, keeping the texture sharp even when close up:

Cycles:


Update

As of this commit, (will be in blender 2.71) texture nodes now have an option to change the interpolation method:

enter image description here

Using Closest will keep the pixels sharp.


Original answer:

You could use this technique, which uses a node setup to scale the UV map:

A variation of the original setup on BA

  • To add Nodes, press ShiftA > Add node in the Node Editor.

  • To create a Node Group, select the nodes you want and press CtrlG to make them into a group, creating the Group input and Group output nodes. Press Tab to toggle editing the group.

  • To use the above group, connect the UV output of the Texture Coordinates node to the UV input of the NodeGroup, and connect the output to the UV coordinates used to map your texture.
    (The Vector input on the texture node):

Example setup

Set the X and Y values to the X and Y dimensions of your texture.

Blender Internal:

Disable Interpolation and set filter to Box in Material texture settings > Image Sampling:

No interpolation BI settings

Viewport

You can disable interpolation in the Viewport by disabling Mipmaps in CtrlAltUUser PreferencesSystem:

Mipmapping disabled

$\endgroup$
  • 1
    $\begingroup$ The only thing I did understand is the picture in the bottom. I am kinda beginner in blender. I don't know how to open group input or texture coordinate. But it seems to work very good for @WChargin and krivar so I think its a good answer if I understand it. $\endgroup$ – joapet99 Aug 28 '13 at 13:06
  • $\begingroup$ @joapet99 I have updated my answer with more detail, hope this helps :) $\endgroup$ – gandalf3 Aug 28 '13 at 18:46
  • $\begingroup$ Is this nodes applied to the texture or the material with the texture $\endgroup$ – joapet99 Aug 29 '13 at 14:34
  • $\begingroup$ @joapet99 these are Material nodes. (So the material with the texture) Note that if you are using Blender Internal render, you don't have to worry about the nodes, You only need those if you are using Cycles. $\endgroup$ – gandalf3 Aug 29 '13 at 18:57
5
$\begingroup$

Scale the texture to 512x512 in your favourite image editing software. Set interpolation to nearest, this is important.

Here is how it is done in photoshop:

Image size in photoshop

Gandalfs answer is IMO the right one.

$\endgroup$
  • 4
    $\begingroup$ the answer by Gandalf is better, as you keep the tiny texture size. Also the textures will keep sharp even in extreme conditions. $\endgroup$ – krivar Aug 27 '13 at 8:30
  • $\begingroup$ Using GIMP. In the interpolation section you can choose between: None, Linear, Cubic, Sinc(Lanczos3). $\endgroup$ – joapet99 Aug 28 '13 at 13:01
  • 1
    $\begingroup$ None seems reasonable. But as everyone poits out, follow gandalfs answer. $\endgroup$ – Gunslinger Aug 28 '13 at 18:25
4
$\begingroup$

There doesn't exist a direct way to do this in Cycles yet it seems. However, a user on the ba forums has devised a node group for this, see Cycles: Getting rid of Texture Interpolation, it has an attached example blend.

enter image description here

For the 3d view, see How do I disable texture filtering?.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.