I've applied all my other modifiers and applied all transformations and I'm just left with a Bevel modifier for my object. And this modifier is causing weird glitches at joints that involve faces with different materials (see that odd little rhombus of red at the bottom right):

enter image description here

I've got Outer Miter set to Arc and have Harden Normals ticked. I'm pretty sure there are no geometry issues (overlapping edges etc.). Using Limited Dissolve and Merge by Distance doesn't improve the situation and in wireframe mode, you can see the mesh is super simple.

With the Bevel modifier disabled, everything looks normal:

enter image description here

And if I set Outer Miter to Sharp, I don't get the look I want at the joints but the odd glitch goes away:

enter image description here

So if I don't want Sharp joints, how can I solve the odd glitch shown up above? What's causing it?

Any help would be much appreciated.

Here's my .blend file (created using Blender 3.1.0)...


And I don't believe it's an n-gon issue either. If I add and apply a Triangulate modifier (with quad and n-gon method set to Beauty) I still see this issue:

enter image description here

The faces above are all triangles and I've increased the bevel amount to make the "glitch" even more obvious.

  • $\begingroup$ If I APPLY the modifier, I can see where the material is applied incorrectly. With Strength set to -1, the closest material should be applied and there are errors. Mitre Outer changed to "Sharp" does a better job but not great. I would report this as a bug. You could also APPLY the modifier and manually apply the correct material to the errant faces until this bug is fixed. $\endgroup$
    – james_t
    Mar 27, 2022 at 16:11
  • 1
    $\begingroup$ Agree with @tempdev.. it looks like a bug. But at least a consistent, and therefore traceable bug. It seems to be in the 'Automatic' (-1) material offset setting, which should split the bevel down the middle at material boundaries. It's getting the boundary 1-off at the end of a patch/arc spread of faces. Have you reported it yet? $\endgroup$
    – Robin Betts
    Mar 29, 2022 at 18:48
  • $\begingroup$ yeah agree definitely a bug with the automatic material offset, it gets confused by the boundaries. but maybe you want to consider using material offset index 0 or 1 instead of automatic, it actually makes it look nice as well. $\endgroup$ Apr 2, 2022 at 11:09
  • $\begingroup$ Thanks for the feedback from everyone. I've now logged this as a bug - developer.blender.org/T97000 $\endgroup$ Apr 3, 2022 at 12:24

1 Answer 1


This is definitely caused by a bug, which you should report here: https://developer.blender.org/maniphest/task/edit/form/1/

In the meantime you could apply the materials, as this seems to fix the issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .