I followed a tutorial on how to use texture paint. However, when I go into sculpt mode, it disappears:

enter image description here

enter image description here

Furthermore, when I do try and sculpt, with Dyntypo enabled, the texture paint has black in some areas that I alter in sculpt mode.

I want to also know if there is a way in Blender to "finalize" or "apply" the texture paint on the mesh so that I would see it in sculpt mode when I have the Viewport Color Type on "Texture," and rid the black spots that come up where I altered the mesh in Sculpt mode.

I ask this because I am also following a tutorial online on how to sculpt a body, and when he turns on Texture as Viewport color type, he is able to see the texture paint in Sculpt mode and make changes to the mesh (with Dyntypo on) no problem.

Thank you, the help would be much appreciated!


1 Answer 1

  1. To show Material Preview hold Z select Material Preview or click on 3th ball on top-right of your viewport. enter image description here

  2. When you enable Dyntopo you will get this warning which mean it will destroy your UV. List item

As beginner I suggest to follow your instructor workflow (sculpting before painting) until finish your course. And current workflow for sculptor Blender has Multiresolution modifier which flexible and powerful.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.