0
$\begingroup$

I have a model, said model has multires modifier, i have created a UV map and have then sculpted onto the multires with the intention of baking the texture (which makes use of the multires sculpt) for a Diffuse and Normal map. Diffuse map went off without a single problem, Normal map seems to completely ignore the multires. I'm using cycles to render but PBR baking it.

I have tried putting on the 32bit float, Setting multires preview to 0, applying to base. Texture nodes

Diffuse Map

Normal Map Failure

Edit 1: Okay so i have changed the title from "Using simplebake addon and the normals bake isn't taking multires into consideration" As i now think the problem isn't with the addon, it's with something else.

As you can see from the new title, I'm using the basic method now, i actually disabled SimpleBake to make sure it's not messing with anything. I've also tested with a secondary model and the same problem is arising, so it's not a problem with this model unless my process of modelling itself is flawed (which i'm sure it can be more efficient but i don't think it's causing this problem). I believe it's a setting somewhere i've played with the bake settings so much i'm certain it's gotta be something that affects the rendering somehow.

These are the current settings and the bake results - Updated Settings and normal bakes

$\endgroup$
7
  • $\begingroup$ There might be a misconception here, you use cycles to bake the normal map (normal map tab) and check multires, then you put the object back to 0 (smooth enabled?) and then you bake, with cycles on the cycle bake panel and check 'bake from multires'. perhaps you can upload the blender file? $\endgroup$
    – Wolfeius
    Commented Mar 15, 2022 at 17:22
  • $\begingroup$ Okay i'm relatively new to blender, i can't find a normal map tab, are you talking about the normal map file? like the final image i have in my post. What do you mean by "check multires"? Is there an option i've somehow missed in the Simplebake settings or is there something in the multires modifier i need to check? If the latter, then there's no "object" option or value in the multires. I cannot find a bake from multires option anywhere when i switch to cycles baking. I'll upload the file for ya to look at. Edit 1: Okay how do i upload this here i see no way of doing so. $\endgroup$ Commented Mar 16, 2022 at 16:46
  • $\begingroup$ yeah, check the docs: docs.blender.org/manual/en/latest/render/cycles/… There is a bake type that you can set to 'normal' and it will bake the normal maps on the image texture node selected or connected to the normal map. to upload a file you can use pasteall.org/blend $\endgroup$
    – Wolfeius
    Commented Mar 16, 2022 at 16:53
  • $\begingroup$ Right that's for base blender baking, as i've stated in the post i'm using Simplebake. It makes the process a lot easier and faster, i just need to figure out this problem and then the addon will save me a whole load of time in the future. Also, pasteall ain't working. $\endgroup$ Commented Mar 17, 2022 at 10:46
  • $\begingroup$ PBR baking is for baking the nodes into image-textures, cycles is for baking normals from multires. check the cyclesbake settings in the addon. I would recommend that you do the tasks first on vanilla blender, so you understand what they are and how to do them before jumping into addons. taking shortcuts sometimes takes longer. $\endgroup$
    – Wolfeius
    Commented Mar 17, 2022 at 12:37

1 Answer 1

0
$\begingroup$

The problem has been solved!!! Thanks to @ShubhamPatilart on twitter for showing me the fix. For some reason i needed to Shade smooth the model and set the Multires "Level Viewport" to 0. If anyone finds this because they had a similar issue and doesn't know how to set the shading to Smooth (i don't blame you i've only used it a couple times), Right click on the model and it's right at the top of the menu. enter image description here

No need to worry about it being destructive though, just right click again and select "Shade Flat" to set it back (it works as a kind of this or that setting so it can easily be switched between.

Ah, lovely normals behaving proper again. enter image description here

$\endgroup$
1
  • $\begingroup$ "For some reason i needed to Shade smooth the model and set the Multires "Level Viewport" to 0." That's because normal maps are baked relative to vertex normals. If you bake a multires at full res onto itself the normal map is zero because all of the information is encoded in the vertex normals. You go to level 0 because that's the mesh you want a normal map for. You can shade smooth or not as appropriate, but the idea is that shading smooth will smooth the vertex normals, making the baked normals do less work and producing a smoother result. $\endgroup$ Commented Nov 24, 2023 at 5:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .