1
$\begingroup$

I'm trying to use Geometry Nodes › Curve to Mesh to create thin curvy walls, and it seems that the thickness of the wall depends on the size (not scale) of the underlying curve. In this screenshot, both curves have a scale of 1.0, but one curve is thicker because it's larger.

Curve to mesh

Is there some way to keep the thickness the same for every curve? Thanks.

$\endgroup$
1
  • $\begingroup$ if you really want to know the reason (and we don't have to guess), pls provide blend file $\endgroup$
    – Chris
    Mar 14, 2022 at 13:08

1 Answer 1

0
$\begingroup$

You have different radius. You can do the following:

enter image description here

Also, then you apply scale for curves, open Adjust last operation F9 and uncheck Apply Properties. This will keep curve radius at 1.

enter image description here

You can also clear curve radius in edit mode, by searching command (F3) set curve radius

$\endgroup$
1
  • $\begingroup$ This is the answer, thanks! It seems that the "Set Curve Radius" node also affects the height of the walls (on top of the quadrilateral dimensions), so I just manually set the radius on my curves. $\endgroup$
    – SugarBear
    Mar 14, 2022 at 13:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .