I just completed the "Endless Flight Loop with Geometry Nodes" YouTube tutorial. When I run the looping animation in the 3D Viewport, in either Material Preview or Rendered Viewport shading mode, the results look fine:

rendered viewport shading mode

but when I render the image, the plane renders properly, but the "topo" lines almost completely disappear:

Actual render

I've disabled the compositor pass with no change and explored a lot of camera, EEVEE, and shader settings, but nothing seems to change the result.

The shader is fairly simple, although it brings in two attributes from the Geometry Nodes:

Shader snapshot

Shader settings seem OK:

shader settings snapshot

The Geometry Nodes screenshot is, of course, unreadable:

Geometry Nodes

Any hint as to what's going wrong in the actual render would be greatly appreciated.

Note: This requires 3.1 geometry nodes.


1 Answer 1


The "Airplane" collection is hidden in the Viewport, but not in the Render ; so the big mesh in this collection blocks the view of the mountain.

Either Disable it for render (in the Outliner, Camera icon), or Exclude it from the view layer (Checkbox icon)

  • 1
    $\begingroup$ Nailed it. I can't believe I missed something that simple. Thank you very much. $\endgroup$ Mar 14, 2022 at 0:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .