5
$\begingroup$

I have Node Wrangler enabled in Blender 3.1 on Windows 10 on a Mac laptop with numpad emulation. With a texture node, e.g. Gradient Texture selected, I press Ctrl and Shift and I see an icon in the lower left hand corner of the shader editor show the left mouse button with the text "Preview Node". I click and nothing happens. Why?

I have tried uninstalling all previous versions of Blender, deleted the Roaming/Blender preferences folders and completely reinstalled Blender 3.1 to no avail.

$\endgroup$
0

1 Answer 1

3
$\begingroup$

Figured it out. You have to click ON the node in question. Even though it seems like it should be creating a node where you click, but it is what it is.

$\endgroup$
2
  • $\begingroup$ Thanks! I had the same problem with 3.2 alpha and it was solved after reading your answer. I'm not sure it was solved by disabling then enabling node wrangler or by your seemingly obvious where to click but it's ok now. $\endgroup$
    – Barbod M
    Mar 17, 2022 at 17:11
  • $\begingroup$ Of course it requires you to click the node you want to preview: previewing a node is not about adding a node in the first place. You are not asking to add a node somewhere, you are asking to preview a specific node that's already there. Node Wrangler's preview is just plugging whatever node you want into the material output, and optionally pass it through an emission shader if the node you clicked isn't a shader itself. And you can click several times on the same node to circle through its different outputs. $\endgroup$
    – L0Lock
    Jun 22, 2022 at 8:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .