0
$\begingroup$

Relatively new user here with what I hope to be a simple question.

Following the method of this video, I applied a .MOV file as a textured material to one face of a cube. When I execute a playback of the scene, the video doesn’t play in the 3D Viewport. And whenever I render the scene the texture appears still—I don’t see the frames pass during the render process.

Here’s a photo of my screen to help illustrate what I’m describing, and here's a link to the Blender file.

Screenshot of workspace

In case it matters, here are my system specs:

  • Ubuntu 20.04
  • Intel i3-10100
  • Nvidia GTX 1650
  • 16GB RAM
$\endgroup$
6
  • 1
    $\begingroup$ pls upload your file:pasteall.org/blend, in my case,it's ok $\endgroup$
    – NatureK
    Mar 12, 2022 at 6:30
  • $\begingroup$ Hi! It appears you meant to leave a link for a video but it hasn't appeared properly in your question. It's okay to just paste a link as text. It seems that your question is answerable without said link but just a heads up :) $\endgroup$
    – Onyx
    Mar 12, 2022 at 7:59
  • $\begingroup$ Oops! Fixed the hyperlink and uploaded the Blender file $\endgroup$ Mar 12, 2022 at 15:23
  • $\begingroup$ maybe try with other video, not a mov or a different codec $\endgroup$
    – alambre
    Mar 12, 2022 at 16:23
  • $\begingroup$ Tried with an MP4 and saw improved results. But, after 100 frames, the rendered video starts to look pretty weird (the output has frames that I can only describe as "jumpy," i.e. the output video seems to skip forwards and backwards randomly). $\endgroup$ Mar 13, 2022 at 1:31

3 Answers 3

1
$\begingroup$

I ended up converting the .mp4 into an image sequence and re-configuring the texture node to recognize it as such (instead of a movie). I used the ffmpeg utility to accomplish this, as described in this question. Not an ideal workaround but it works well.

$\endgroup$
1
$\begingroup$

I just had a similar problem placing an MP4 file as an image texture (Movie). I couldn't see the movie in the viewport or when rendering. But it was displayed in the "Image Editor Tab".

I deleted the "Principal BSDF" and then added a new "Principal BSDF". After reconnecting the nodes (Color > Emission), it finally worked.

I could not find the error in the previous BSDF.

Settings now:

enter image description here

$\endgroup$
0
$\begingroup$

I also tried converting to an image sequence (make sure each image ends in the format -0001, -0002) and it also fixed this problem. The other solutions didn't end up working. What's weird is that I have 8 of these textures and only the last 4 of them in my project didn't work.

EDIT: Spoke a bit too soon, there's still odd issues with this. Checking Cyclic did get it working again, which seems to indicate this might be because of a mismatch between frame number / start frame / offset making the image texture only display the first or last frame and just sitting there. Not sure yet, I'm definitely a beginner here!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .