4
$\begingroup$

Whenever I add a Subdivision Surface modifier to any object, it immediately disappears from the screen. It does not matter what kind of object I apply the modifier to. When I switch to editing mode, I can see the wire frame with the nodes of the object, but not its actual surface. In object mode it is just completely invisible. Do I need to change a setting?

Before adding modifier enter image description here

With modifier enter image description here

$\endgroup$
6
  • $\begingroup$ could you please show some screenshots? It may help to understand what's happening, or even share one of your objects $\endgroup$
    – moonboots
    Mar 10, 2022 at 10:50
  • $\begingroup$ Does this happen in all your blender projects or just with a specific file? If it's the later one can you please share the file? $\endgroup$ Mar 10, 2022 at 11:03
  • $\begingroup$ It happens in all of my projects. And I added some screenshots. $\endgroup$
    – user143590
    Mar 10, 2022 at 11:13
  • $\begingroup$ it looks like a bug, is it the same with the previous versions of Blender? $\endgroup$
    – moonboots
    Mar 10, 2022 at 11:23
  • $\begingroup$ Yup, it works fine in 3.0.1. Thanks! Should I report the bug somewhere? $\endgroup$
    – user143590
    Mar 10, 2022 at 12:10

1 Answer 1

15
$\begingroup$

The same problem occurred to me and I have fixed it.

Click "Edit > Preferences..." on the menu bar to open the Preferences Window. Then Switch to the "Viewport" Tab, click "Subdivision" and uncheck "GPU subdivision" below. Now the object should be visible.

Preferences Window

I don't know if it is caused by my old GPU or a software bug. My GPU is AMD Radeon R9 370. My Blender version is 3.1.0.

Hopefully helpful.

$\endgroup$
1
  • $\begingroup$ i was about to create the same question but this post pop up and thanks for your answer. $\endgroup$ May 7, 2022 at 8:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .