1
$\begingroup$

I hope isn't a repeat of a question but I couldn't find anyone that had asked it. Basically, I'm trying to use the subsurface modifier with the "simple" option applied, however, it doesn't show on the viewport until the modifier is applied. I've unchecked the "simplify" check-box on the "render preferences" tab but still no luck. I've tried increasing the number of subdivisions, I've tried to add the modifier when on in the object mode but again no luck. Also, I've completely uninstalled blender and reinstalled but that didn't help either Has anyone had this problem before and, if so, did you find what may be happening? Anyways, any information on this would be greatly appreciate and hope you all have a great rest of the day!

$\endgroup$
7
  • 1
    $\begingroup$ Uncheck the box that says "Optimal Display" in the modifier settings. $\endgroup$ Mar 8, 2022 at 18:40
  • 2
    $\begingroup$ What are you excpecting to see? As it is a modifier the subdivision doesn't exist until you apply the modifier, You can only see the wireframe if you enable the Wireframe option in the Viewport Overlays and disable Optimal Display in the modifier, as Christopher says $\endgroup$
    – moonboots
    Mar 8, 2022 at 18:43
  • $\begingroup$ Thanks Christopher unfortunately that doesn't help with this situation for some reason. @moonboots, thanks for the reply too. So what I'm expecting to see is a change in the wireframe after adding the modifier. The wireframe only changes after the modifier is applied so there is no preview of what it would look like $\endgroup$ Mar 8, 2022 at 20:20
  • $\begingroup$ as I said you can see the wireframe if you enable this option in the Viewport Overlays panel, if it doesn't work please share this object: pasteall.org/blend $\endgroup$
    – moonboots
    Mar 8, 2022 at 20:23
  • 1
    $\begingroup$ @ChristopherAustin you need to uncheck Optimal Display under the modifier to see the modifications in the wireframe, if you don't do that, you won't see anything. If you've done that and still don't see changes, you should share your file or at least some screenshots. $\endgroup$ Mar 9, 2022 at 6:33

2 Answers 2

0
$\begingroup$

here as a small demo how you should do it and what you can see.

If this doesn't work for you...maybe you got some hardware problems.

But it is just visualized what Christoph Bennet and moonboots wrote in the comments.

enter image description here

Steps are:

  1. turn on wireframe enter image description here

  2. turn of optimal display in modifier

$\endgroup$
3
  • 1
    $\begingroup$ That worked this time! I honestly have no idea what I did different because I was thinking I did that. Anyways, thank you so much for the help!! $\endgroup$ Mar 9, 2022 at 16:52
  • $\begingroup$ happens....happened to me 100x before ;) $\endgroup$
    – Chris
    Mar 9, 2022 at 17:19
  • $\begingroup$ one more thing... make sure you're not in edit mode. im using 3.4 and there seems to be a bug where catmull preview works in edit mode but not for "Simple" $\endgroup$
    – dtc
    Jan 28, 2023 at 17:57
1
$\begingroup$

It turns out to be a crashing issue with GPU subdivision in Blender 3.12.

You can fix it for now by uncheck GPU Subdivision in Preferences > Viewport > Subdivision.

$\endgroup$
1
  • $\begingroup$ That's it! With a graphics card not supporting GPU (Cycles) rendering (a Radeon R7 200), the cube disappears (I see a line in wireframe mode). If I deactivate the option, it works as expected! Thanks. $\endgroup$
    – PhiLho
    Sep 22, 2022 at 21:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .