1
$\begingroup$

I downloaded a marble material for my project and when I applied it on some of the faces it doesn't follow the face's normals.

I UV unwrapped all my meshes I want the texture on, tried different nodes, but nothing seemed to solve the problem.

The pillars are all separated objects on the picture below.

enter image description here

My shading node setup looks like this:

enter image description here

If I connect it to a UV node or the UV point of the texture coordinate the biger faces (like the floor) will get pixelated even tho only the floor and all faces facing Z or -Z axis are good.

By pixelated I mean it will look like this:

enter image description here

When I say the texture doesn't follow the face rotation I mean something like this. It's a beveled edge and as you can see the faces facing Z or -Z axis are perfect, but as it rotates more and more to faceing X/-X/Y/-Y direction (basically rotating 90 degrees) it will get more and more streched.

enter image description here

And this is how a UV map looks on a pillar (all the same on each pillar)

enter image description here

If you could help it would be much appriciated!

$\endgroup$
8
  • 1
    $\begingroup$ First thing, you need to use the UV output of the Texture Coordinate if you plan to use the UV unwrap $\endgroup$
    – moonboots
    Commented Mar 7, 2022 at 19:40
  • $\begingroup$ I tried, but with that biger areas (faces) like the line on the ground will get pixelated, like if it zoomes in on the texture a LOT. Another problem with that is this way all the pillars would look the same. $\endgroup$
    – Csabesz07
    Commented Mar 7, 2022 at 19:51
  • $\begingroup$ please pack your image (File > External Data > Pack Resources) and share your file (only one pillar): pasteall.org/blend (copy paste and share the URL) $\endgroup$
    – moonboots
    Commented Mar 7, 2022 at 19:52
  • $\begingroup$ pasteall.org/blend/c0b66dc8a2b54a5c8fa7127eb265475d Sorry it took a while I used this method for the first time $\endgroup$
    – Csabesz07
    Commented Mar 7, 2022 at 20:01
  • 1
    $\begingroup$ What you can do is use the Box setting instead of Flat in the Image Texture node, not sure why you don't prefer the UV outpur though, it should not get pixellated if the unwrap is good $\endgroup$
    – moonboots
    Commented Mar 7, 2022 at 20:29

1 Answer 1

3
$\begingroup$

Use the Box setting instead of Flat in the Image Texture node, it will project the texture on the 3 axis:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .