0
$\begingroup$

How can I get alpha-transparent surfaces to actually behave transparent when rendered?

When I make a shape and set its material to one with alpha transparency:

Base colour dialogue for the material on this shape.

The Layout shows me the material is 70% transparent, as specified:

enter image description here

When rendered, though, that shape turns opaque:

enter image description here

Where do I need to change something so the shape and light behave as they do in the Layout workspace?

If it matters: this is Blender 3.0.1. I'm very new to using Blender and if there are settings or functions you name, I probably don't know where they are.

$\endgroup$
2
  • 1
    $\begingroup$ There's an "Alpha" socket on the Principled BSDF material (separate from the alpha channel in "Base Color"). Does that setting work for you? $\endgroup$ Mar 4, 2022 at 0:19
  • $\begingroup$ hello could you please share your file? pasteall.org/blend $\endgroup$
    – moonboots
    Mar 4, 2022 at 5:41

1 Answer 1

0
$\begingroup$

A material has a “Blend Mode” property.

By default, this was set to “Opaque”.

When I set the property to value “Alpha blend”, the surface is correct transparency in the rendered image.

$\endgroup$
1
  • $\begingroup$ Already had this, not the issue for me :( Any other ideas? $\endgroup$
    – pixelpax
    Oct 25, 2022 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .