I'm sculpting a character in Blender, and I'm attempting to hide parts of it using face sets. When I use the Draw Face Sets tool, the face set appears to have holes in it:

The face set, appearing to have holes in it.

For reference, the topology of the sculpt looks like this:

The topology of the sculpt.

And when I hide everything but the face set, it looks like this:

Just the face set, with everything else hidden.

I use Dyntopo to control the exact amount of detail throughout certain parts of the sculpt, but I can't seem to draw face sets at all unless I temporarily disable it.

Can anyone pinpoint the cause of this? Thanks in advance!

Update: It looks like I can make perfectly good face sets using Box Face Set, but still not with Draw Face Sets. Why is this?

A face set made with box face set.


1 Answer 1


(Please read the update at the end of this post btw)

I found two solutions!

The first solution I discovered was setting Propagation Steps to anything higher than 1.

Setting Propagation Steps to 2.

Checking Topology under Auto-Masking had the same effect!

Checking the Topology checkbox.

Now I can draw solid face sets.

A solid face set.

Update: I think i just found the true underlying issue here. I realized that I couldn't "extend" face sets by holding ctrl, nor could I smooth them out using shift. I created a new file and experimented with a subdivided default cube in attempt to trace back to the root of the problem.

First, uncheck everything under Brush > Advanced > Auto-Masking, like so:

Auto-Masking settings with everything unchecked.

No need to increase Propagation Steps unless you know what you're doing (I don't).

Next, under Options in the top right of the Viewport, ensure that everything under Auto-Masking is unchecked.

Auto-Masking settings with everything unchecked.

You're all set! Draw Face Sets should function normally, exactly as it would in a fresh .blend file.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .