3
$\begingroup$

Text Text Text

I've tried recalculating bone roll before applying IK. I've tried offsetting the knee join so its not perfectly 180 from the upper leg. I've tried deleting excess bones use for cloth on other rigged attachments.

Nothing seems to prevent the wild inaccurate rotations.

The chain length is 2, the pole angle is 90 degrees, this also happens without a pole target bone.

File: [edit] Removed file for privacy

$\endgroup$
2
  • $\begingroup$ hello please share your file (at least the armature): pasteall.org/blend $\endgroup$
    – moonboots
    Commented Feb 28, 2022 at 16:59
  • $\begingroup$ Never knew about pasteall for blend files, thanks! $\endgroup$
    – Frofidor
    Commented Feb 28, 2022 at 17:02

1 Answer 1

2
$\begingroup$

You have your IK Target parented to the Left knee. That creates a bit of confusion for the IK solver, because it creates a dependency loop: parenting conflicts with the IK constraint. Remove the parenting from IKTarget_Left and the problem will be resolved.

  • Select the armature.
  • In Edit mode, select IKTarget_Left
  • Go to the Relations panel and click the 'x' to remove the Left knee as parent:

IKTarget_Left showing Left Knee as parent

$\endgroup$
2
  • 1
    $\begingroup$ Solved! I figured this was something easy I missed... $\endgroup$
    – Frofidor
    Commented Feb 28, 2022 at 17:12
  • 1
    $\begingroup$ pretty much anytime you get jumpy behavior from a rig it's because of a dependency loop. I trip over this specific problem all the time myself. $\endgroup$ Commented Feb 28, 2022 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .