2
$\begingroup$

I'm doing an animation of a zombie character dancing and at one part i want his arm to fly off and detach. However, when i try to keyframe the object of just the left arm flying off it gets very warped because it's binded to the armature. Any ideas? See screengrabs.

How i have it setup:

  1. I made each arm a separate mesh
  2. They're all binded to the armature and work good for the animation
  3. In object mode i'm trying to keyframe the arm flying away and it gets super warped.

help!

enter image description here

$\endgroup$
5
  • $\begingroup$ Change the parenting of the two bones that make up the shoulder so that the upper arm bone is not connected to the shoulder bone. Then do the animation using the armature and simply move the upper arm bone -- the rest of the arm bones will follow. $\endgroup$ Feb 26, 2022 at 23:48
  • $\begingroup$ I'll lose my animation if I change all the parenting right now and have to redo. Is the a quicker fix? $\endgroup$
    – Steve Cady
    Feb 26, 2022 at 23:55
  • $\begingroup$ hmm... parenting, well 'connected' setting in the parent relationship should be something you can keyframe, but it's not working for me in 2.93. My second guess to try would be to see if you can do something with the vertex groups, but short off that, I think you're going to have to lose the part of the animation that starts where the arm starts to fly off $\endgroup$ Feb 27, 2022 at 0:40
  • 3
    $\begingroup$ I think my cheat solve… Will be to make the arm mesh disappear via key frame transparency. Have another arm appear in the same location and key frame the arm falling off which would have no armature on it. $\endgroup$
    – Steve Cady
    Feb 27, 2022 at 0:52
  • 1
    $\begingroup$ It's not cheating if it works. ;) $\endgroup$ Feb 27, 2022 at 1:00

0

You must log in to answer this question.

Browse other questions tagged .