4
$\begingroup$

I have a mesh (converted from a curve and extruded with solidify modifier).

enter image description here

As can be seen, the curved surface in the top show the flat faces.

I want to smooth this edges:

enter image description here

And keep sharp this edges:

enter image description here

If I apply a shade smooth globally in the mesh, I get this wrong result:

enter image description here

Even if I mark the edges as sharp, the result is the same. Is it possible smooth the edges in the curved surface and keep the other edges sharp?

This is the Blender file

Thank you.

$\endgroup$

1 Answer 1

6
$\begingroup$

After you've shade smoothed, use the Auto Smooth option, it will determine under what angle the smooth will happen (the artefacts around the inner hole happen because Blender tries to smooth between these faces and the faces of the hole, which are 90°):

enter image description here

You can also select the faces you want, press CtrlF to access the Face panel and choose Shade Flat (if you want to easily select all these faces, select one then press ShiftG (Select Similar) > Normal):

enter image description here

Also maybe you should simplify these faces with a X > Limited Dissolve.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .