i ma new to blender...i have two faces...while i enable snap to face with tick the project on to self and project individual elements...and hit g and enable proportional editing...the below surface overlap the upper ones...while i want upper surface cover below surface without overlapping..but the final screen is like this enter image description here


1 Answer 1


This is a classic caveat of snap-to-face. I'm assuming you have it set to "closest". All vertices will snap to the closest face to the camera. In this instance, it has the side effect of causing some vertices which were previously on one side ("below") of the surface to snap above it.

A mesh isn't explicitly always a proper shape; so we have to watch for these things, and outside of looking at normals, all vertices look the same internally. So non-manifold meshes are unfortunately perfectly possible here, and the tool is actually working as intended. So let's look at how we get around your problem...

The best way around it is to snap it one side at a time—only select the vertices closest to you, snap them, then change your view position and move on to the rest. (If you're fortunate and only have two sides to worry about, you can press Control+I to simply invert your edit mode selection; then switch sides. It's hard to say how that will work for your torus, though.)

Another option is the Shrink Wrap modifier, which also allows you to fit one mesh over another and even provides an offset. If this sounds complicated, you might see if Shrink Wrap does the job better for you!

Speaking of meshes not always being proper shapes, the last thing I can suggest—bearing in mind that I'm not sure what your end goal with this project is—is to try out some of the non-mesh shapes like a NURBS torus or a curve. They have their own issues, but they don't have this one, and when you have your final shape figured out with them, you can press F3 and "Convert to Mesh"; and it will produce a mesh matching that shape.

Welcome to the community!

  • $\begingroup$ i apply shrink wrap but still problem exist $\endgroup$
    – M.shahbazi
    Feb 24, 2022 at 13:41
  • $\begingroup$ Hmm... You might try checking your topology and normals then. If you go to edit mode, select all vertices, and F3→Smooth Vertices, it might help sort it out (options will pop up in the lower left of the viewport, they're easy to miss). Also, try turning on normal checking (edit mode, box in the top-right of the 3D Viewport that looks like a Venn diagram, normals are at the bottom of its menu) and make sure they're all facing the same way; if not, select all of them and F3→"Recalculate Outside"; then try it again. Either one could mangle this. $\endgroup$ Feb 24, 2022 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .