2
$\begingroup$

I have model with what should be a completely flat base that I want to 3D print.

It has "many" vertices on the bottom. They look level, but there are slight variations in about 60% of them, extremely slight. This is causing all kinds of havoc with the bottom layer of my print when I slice it as it's not giving me a totally flat base which is effecting how it adheres to the bed.

In Blender, when I use the box tool to select all of these vertices, I try to past in a single value for the X for everything that I've selected, but the value doesn't get pushed out to all of them.

I've tried using the flatten command in Loop Tools, but this only seems to make things worse/weirder.

Is there another way to give all of these vertices the exact same X value?

$\endgroup$
1
  • 2
    $\begingroup$ SX0 should do it, no? And you can choose the 0 reference in the Transform Pivot Point panel $\endgroup$
    – moonboots
    Feb 22, 2022 at 20:25

2 Answers 2

2
$\begingroup$

In Edit mode select the vertices and Scale to 0 on the axis at issue, in this example on the X axis (SX0):

enter image description here

Now that all the vertices are in the same position on that axis, all their positions can be set (in this example to -0.25) in the axis' Median field (Sidebar/N-Panel > Item tab > Transform > Median > axis field) at the same time:

enter image description here

Tip: check your Transformation Orientation, you don't want to do this on Local when you need Global, or vice versa. Also check your Transform Pivot Point, although Median Point (the default) works in most instances you'll sometimes find others (especially 3D Cursor) more usefull.

$\endgroup$
1
  • 1
    $\begingroup$ I missed the Scale to 0 on the axis. It all makes sense now. $\endgroup$ Feb 23, 2022 at 20:14
0
$\begingroup$

Flatten has several options that can help you achieve what you want.

If you want to flatten on the X axis, then set your viewport to the right orthographic view using Numpad 0, run the Flatten operator, and adjust its settings to View plane and lock both Y and Z axes:

Flatten settings picture

Another solution is to just scale your selection to zero on the X axis, which you can do by pressing:
SX0⏎ Enter.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .