1
$\begingroup$

enter image description here

So I have this in nodes but then in render, it stay grey. I hope someone knows whats the problem.

enter image description here

$\endgroup$

2 Answers 2

4
$\begingroup$

You should enable transparency in Render settings:

Render Properties → Film → Transparent

enter image description here

$\endgroup$
4
$\begingroup$

The Background Images option in the camera settings is for adding reference images in the 3D Viewport, for example to position objects correctly if you are planning to Alpha Over the render in the Compositor as you tried to. They will not be rendered.

The reason the background stays grey in render is that 1. (as said before) the reference background image will not be rendered and 2. the World background is not considered transparent by default. To use Alpha Over in the compositor, the background behind the object has to be transparent. To make the World transparent, go to Render Properties > Film > Transparent and enable it.

film transparent

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .