1
$\begingroup$

I have been using markers in the timeline and pressing Ctrl + B to change the active camera throughout my Blender animation. When I press play in the 3D viewport it changes the active camera at the markers as I want it to, but when I render the animation, the view stays on the first active camera and doesn't change.

$\endgroup$
1
  • $\begingroup$ pls provide example blend file $\endgroup$
    – Chris
    Commented Feb 21, 2022 at 6:15

1 Answer 1

1
$\begingroup$

Make sure that you don't have View > Local Camera enabled in the 3D Viewport. If this is the case, your animation will only be rendered from the camera which is selected there.

If you have a second 3D Viewport where the option is disabled, then this viewport will correctly show the switching between cameras. Only the Local Camera viewport will use just one camera.

The strange thing however is, when I test it, as soon as I have a second viewport where the switching works, it works in rendering, too. So if my answer doesn't help we maybe need your file to investigate further.

local camera

$\endgroup$
2
  • $\begingroup$ My local camera setting was off on both viewports and it still doesn't change int he render. $\endgroup$ Commented Feb 22, 2022 at 18:53
  • $\begingroup$ Then maybe you should upload your file as Chris suggested if all settings should be correct for rendering... $\endgroup$ Commented Feb 22, 2022 at 22:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .