After I applied my subdivision modifier, the top circle now has this weird zigzag pattern. Is this normal? If it isn't, why did this happen and how do I fix this?enter image description here

This is how it looked like before applying my subdivision surface modifier. enter image description here


2 Answers 2


It is normal, that's because the tip of your geometry is made of a ngon. The subdivision algorythm created a vertex in its center, created the new geometry from it.

If you activate the wireframe overlay and disable the Subdivision Modifier's Optimal Display option, you can actually see the final mesh beforehand:

demo wireframe

Because of how this subdivision algorithm works, you can't really avoid that.


L0Lock is right the problem lies in the algorithm of the Subdivision Surface Modifier. However, there is a way to trick the modifier a bit.

Recently I ran into a similar problem as you, with the Subdivision Surface Modifier creating some not-so-pretty geometry. Especially when Shade smooth is enabled (Figures 1 and 2).

Fig. 1 Unmodified geometry, Subdivision Surface Modifier applied, and Shade Smooth enabled (from left to right)

Fig. 2 Close up of geometry in Fig. 1

The following solution led to a good result in my case:

  1. as already mentioned, the problem is the n-gon at the "top" of the geometry. Here I start by inserting an inset (I). Now I dissolve every second edge of the resulting ring (Figure 3).

Fig. 3 Inset added to the "top" n-gon of the geometry. Every second edge was selected to be dissolved.

  1. I repeat this until I obtain a square in the middle again (Figure 4)

Fig. 4 The obtained geometry obtained after repeating the first step two times.

  1. (optional) I move the obtained faces a bit forward to get a rounder surface in the end (Figure 5).

Fig. 5 Slight adjustment of the geometry to achieve a more round surface in the end.

  1. Finally, I apply the Subdivision Surface Modifier again. This gives me the following geometry (Figure 6).

Fig. 6 The geometry obtained after applying the Subdivision Surface Modifier.

Now I can also activate Smooth Shading and obtain the result shown in Figure 7.

Fig. 7 The obtained geometry with Shade Smooth enabled. Overview (left) and close up of the tricky section (right).

What this technique does is practically spread the problem across multiple faces. Whereas my previous geometry had a 32-gon before applying the Subdivision Surface Modifier, it instead contains 28 5-gons and a quad after the changes described above. The Subdivision Surface Modifier seems to handle this much better.


Not the answer you're looking for? Browse other questions tagged .