2
$\begingroup$

I made an overlay using blender and wanted to export it with a transparent background. To that end I followed the usual guides (select transparent, ffmpeg Quicktime - Qt encoding).

When I import the overlay into After Effects, it complains that

The item has an unlabeled alpha channel.

If I select "Premultiplied - Matted with Color #000000" to interpret the footage then everything works just fine in AE, that is the overlay works immediately as expected.

However, in Blender's own video editor, the overlay just doesn't work. It shows as having a black background! I've tried Alpha Over and just about everything else in the dropdown. It works with image sequences though.

Tried this in 3.01 and 2.93 without luck.

EDIT: Also tried it in a fresh project with just the default cube. Same issue there.

EDIT 2: If I use blender 2.83 it works fine. The transparent bg .movs exported from 2.93/3.01 work as expected in 2.83 video editor.

Is this a bug or was the way transparent background movie clips are handled changed intentionally?

$\endgroup$
5
  • $\begingroup$ pls provide a simple blend file with your problem $\endgroup$
    – Chris
    Feb 14, 2022 at 5:38
  • 2
    $\begingroup$ Well, movie files with transparency are quite tricky. It seems the Blender Video Sequence Editor doesn't support premultiplied videos with alpha channel. If you instead import the movie into the Compositor it works as expected. Generally I would always suggest for best quality etc. to render frames in a format which is best to work with in the software you intend to use for further adjustments/composition. $\endgroup$ Feb 14, 2022 at 9:21
  • $\begingroup$ @GordonBrinkmann I was just editing. I'll see if I can do what I want in the compositor in a current version, thanks for the hint. Version hopping is apparently also an option. $\endgroup$ Feb 14, 2022 at 9:26
  • 1
    $\begingroup$ For example if you're going to use it in Blender VSE, then if you render the frames as images in OpenEXR format, an imported sequence will by default be set to Color Space > Linear and Alpha > Premultiplied. These settings don't even exist for an imported movie in the VSE. The difference in the Compositor is, it uses color space and alpha correctly when you import the Quicktime movie. Maybe there is some magic setting somewhere in the VSE, but I haven't found it yet. It seems like the "Add Movie Clip" option is made for "standard" videos that don't accept transparency. $\endgroup$ Feb 14, 2022 at 9:28
  • $\begingroup$ @GordonBrinkmann Yes, image sequences worked like a charm, in the newer versions, too. $\endgroup$ Feb 14, 2022 at 9:31

1 Answer 1

0
$\begingroup$

Did you check the Proxy tab?

Here is what worked for me:

  1. Click on the video strip that needs to be on top.
  2. On the right side on the Strip tab
  3. Under Composition select Alpha Over.
  4. Then click on the tab called Proxy, click on that and unblock 100%.
  5. Then go back to the Strip tab and right next to that word Strip is a little check mark. Uncheck it and check it again and it works in my case.
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .