I rigged and animated a character with two arms, and animated them fine in the viewport, but when I render it, one arm doesn't show its animation.

I tried re-rigging the same arm, and it still won't render, but I don't know why?

Any help is appreciated, this is with blender 3.0.1.

enter image description here

file is here: https://1drv.ms/u/s!AsMd41H8L3b6meJUwCP8viVj7Sqx_A?e=rJ6R0r

  • 1
    $\begingroup$ i just tried with blender 3.2 ...it works. Did you try to update Blender? $\endgroup$
    – Chris
    Feb 10, 2022 at 6:43
  • $\begingroup$ The arm is a child of the body mesh (greggC) and deformed by the armature which is also a child of greggC. I'm not sure if this messes up something and why the other arm works. But usually, the armature is the parent of the deformed mesh. Then Blender can automatically add and remove the needed Armature modifier. Now, when you remove the Armature modifier from the arm, then make it a child of the armature (Parent To > Armature Deform) and check Keep Transform then it works again (Blender 3.0) => i.stack.imgur.com/XQcvW.jpg $\endgroup$
    – Blunder
    Feb 10, 2022 at 18:52
  • $\begingroup$ @Blunder That works perfectly! I guess I did the arms a little too quick and dirty there, and carelessly parented the armature after. Thank you. $\endgroup$
    – PNG1
    Feb 11, 2022 at 3:28

1 Answer 1


This was due to bad armature hierarchy, most likely, according to Blunder. Usually armature is the parent of the deformed mesh. But to fix...:

  1. Remove armature modifier from unruly arm mesh
  2. Select arm bone, select armature, make arm bone child of the main armature
  3. Re-add armature modifier to arm mesh, re-targeting the main armature again

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .