5
$\begingroup$

Im trying to joined basically the cube to armature but for no reason the cube move down when I export it and deform itself, can someone tell me why please ??
Here is how its representated by Blender enter image description here

And in game enter image description here

And here is file of interest https://www.transfernow.net/dl/20220209IUpM5wLh

Thanks for your futur help !

$\endgroup$

1 Answer 1

5
$\begingroup$

Part of it is because your scale is not 1. In object mode, select your armature, use ctrl-A and apply scale. Some things will move around and it may play around with your other rigged mesh but as a standard practice, ALWAYS apply your scale :)

enter image description here

Secondly, it seems that your cube's vertex weights are not uniform. If they were, it would all be one colour in Weight Paint mode:

enter image description here

You'll want all your vertices in this cube to have a weight of 1 so that they all get affected uniformly by the rotation of the head bone.

This can be done in Weight Paint mode or (more easily) in Edit mode. Select all vertices, and in the object data properties tab (green triangle), click the avatar head bone in the vertex groups panel, set the weight to 1 and click Assign:

enter image description here

When I did this, it didn't fully fix it and, having looked again, that's because the cube is also weighted to other bones in the armature. I recommend either deleting the other vertex groups, setting their weights to 0 or, in future, parent objects like this to individual bones within the armature rather than using (automatic or otherwise) weight paints. Hope that helps!

$\endgroup$
1
  • $\begingroup$ Thank you for reply !! Thank you for you explanations too ! you amazing ! its working now thanks a lot my friend $\endgroup$ Feb 9 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.