3
$\begingroup$

I tried to create a simple marble run using tracks build from bezier curves. But something doesen't seem to work correctly, my marble always jumps around as it hit's the tracks.enter image description here

https://drive.google.com/file/d/1itpHTFTR-iJt7M6UnC3Un2sz9M4MEuu5/view?usp=sharing

$\endgroup$
0

1 Answer 1

4
$\begingroup$

I don't know why but if you simplify your rails topology it will work better: Select an edge ring, go into the Select panel > Checker Deselect, then set the Selected value to 3:

enter image description here

Then again Select > Select Loops > Edge Loops:

enter image description here

And CtrlX to dissolve the edges. Delete the bake, apply the sphere scale, play the animation again, it will work fine.

$\endgroup$
4
  • 1
    $\begingroup$ @TrytoFly Additionally to this solution (where I had the sphere still make some strange bounces further down the rails) I would suggest to lower the value under Rigid Body World > Settings > Substeps Per Frame. In your file it's 250, and although more calculations per frame should lead to better results, sometimes less can be more. I've set it to 25 and it works just fine. But only together with moonboots answer, just lowering the substeps won't be sufficient. $\endgroup$ Feb 8, 2022 at 9:14
  • $\begingroup$ oh ok I didn't see that $\endgroup$
    – moonboots
    Feb 8, 2022 at 9:16
  • $\begingroup$ Was just an idea... after still getting some bounces I looked into those settings to actually increase the value because I thought it might be too few substeps. But when I saw how high the value was I decided to try the other way and decrease. $\endgroup$ Feb 8, 2022 at 9:20
  • $\begingroup$ You guys are awesome, thank you! I was changing values up and down for hours, this did exactly solve my problem. Although i don't quite understand why it was jumping around so violently. $\endgroup$
    – TrytoFly
    Feb 8, 2022 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .