I know this has been asked and "answered" elsewhere, but still...

I'm using Blender 3.0.1-2 in Arch Linux, and I'm unable to transform an object unless I'm in edit mode. The only exception to this is the camera and light source, which I can grab and move around.

I've searched around for answers to this issue and everything points to unchecking the origins, locations, and parents checkboxes under Options>Transform>Affect Only, however, they are already unchecked. Also looking under Item>Transform all of my X,Y,Z coordinates for Location, Rotation, and Scale are unlocked, so should be editable.

enter image description here

Similarly, if I'm working with a plane or text, I can't just select the object press "G" and then a letter corresponding to an axis to quickly adjust it.

Is there anything else I'm missing?

Thanks for your help.

  • $\begingroup$ That is happens if you restore factory settings? $\endgroup$
    – Crantisz
    Feb 7, 2022 at 14:12

1 Answer 1


Ah just solved this exact same problem. Turned out to be an NVIDIA driver problem (weirdly enough). Basically, I wasn't using the GPU on my linux machine (I checked settings > details and saw that the graphics section said "llvmpipe" and not something about my gpu). To resolve this, I installed the nvidia drivers for it (sudo apt install nvidia-driver-515), rebooted my machine, and verified that my computer now uses my gpu. And now blender works fine. I have no idea how my gpu has anything to do with objects not moving in blender though.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .