0
$\begingroup$

** I am new to Blender

I am trying to model and export a Glock 18 for my game. In viewing in Edit mode, Object mode, Shading or basically every mode in Blender, the weapon looks fine and doesn't get distorted until exporting the object to .obj format. Exported .obj file

Here's what it looks like in Blender: Object

And here's its wireframe: Object wireframe

Is there anything wrong with the wireframe or how I exported it that affected the .obj file? Any answer is appreciated.

$\endgroup$
6
  • $\begingroup$ Did you apply the scale to all the objects it is made from before exporting? $\endgroup$
    – John Eason
    Feb 7, 2022 at 9:31
  • $\begingroup$ I kept the original scale. I also tried to import it as an .fbx file and it has the same error, so the problem must be with the wireframe. However, when I imported it into Unity and Unreal, both objects aren't distorted. I'm really confused $\endgroup$
    – rushBblyat
    Feb 7, 2022 at 9:48
  • $\begingroup$ You'll need to upload the blend file ( pasteall.org/blend ) in that case so that someone can have a look. $\endgroup$
    – John Eason
    Feb 7, 2022 at 10:16
  • 1
    $\begingroup$ Looks like triangulation problem. Transform all your non coplanar faces to triangles before exporting $\endgroup$
    – Gorgious
    Feb 7, 2022 at 11:01
  • $\begingroup$ pasteall.org/blend/aeb1a95eb16b4930b4af0fd859e7ea9c // Here's my .blend file, excuse the crappy modelling because I'm new. I also followed @Gorgious instructions and it still doesn't work. :( $\endgroup$
    – rushBblyat
    Feb 7, 2022 at 11:44

1 Answer 1

1
$\begingroup$

Try to recalculate normals in blender.First, face orientation: enter image description here

2nd, switch to edit mode, select all the vectors, edges and faces, choose normals under mesh: enter image description here

3rd, choose recalculate outside.

Here is an example more detailed:

https://www.youtube.com/watch?v=7sK2pDByXOE

A similar face-missing problem, where they recommend to recalculate normals.: https://www.reddit.com/r/unrealengine/comments/s5u5ve/missing_texturemeshes_in_import_from_blender_to/

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .