1
$\begingroup$

So, I'll try to keep it simple. I'm just trying to overlay a transparent image texture on top of another image texture. I've followed various examples on this and I'm just not getting the same results. I've included my node set-up and what my model looks like as a result.

I will also note that although I've got each image texture set to a specific UV map, the texture currently displayed on the model changes as I click between them. Not entirely sure why that's happening either lol...

enter image description here enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ I haven't checked your file but in the first screenshot, the values for the UV maps are red. That's an error and Blender tries to tell you they are invalid. Are you sure the names are correct? $\endgroup$
    – Blunder
    Feb 6, 2022 at 2:42
  • 2
    $\begingroup$ I think Blunder is correct - you changed the named of your uv maps to HeadMap and EyeMap respectively, but didn't change the nodes to reflect that (as they say UVMap and UVMap.001). Click the box and pick the maps by name. $\endgroup$ Feb 6, 2022 at 5:34
  • $\begingroup$ @Blunder & Christopher, swapped the UVs and nothing changed. $\endgroup$
    – SlainChops
    Feb 6, 2022 at 8:31

1 Answer 1

1
$\begingroup$

You need to fix the UV names in the node setup, and choose Viewport Shading mode Material Preview or Rendered.

In the Shader Editor, you will see that the names of the UV maps for UV map nodes are displayed in red. That's an error and Blender tries to tell you they are invalid. Choose the correct names for the UV maps.

Nothing will change because you are still in Viewport Shading mode is still set to Solid with Color set to Texture as you can see here:

shading type solid with shading options

This shading mode uses the Workbench render engine which is a very simple render engine. It uses the image texture of the active Image Texture node and displays it. This causes the texture to change when you click on the nodes. It's useful for texture painting so you see what you paint. But it also simply uses the transparency of the image - which hides the face.

To see the result of your node setup, switch the Viewport Shading mode (Z) to Material Preview or Rendered. There are also options when you open the dropdown menu right next to the sphere icons.

I've added an Area light to the scene and enabled the Use Scene Lights and Scene World options. This is the result:

screenshot

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .