0
$\begingroup$

for some reason my shading looks extremely weird. The Topology is a bit messy in some places, but it shouldn't affect the areas as much I think. I also activated smooth shading, but it doesn't really work. either with or without auto smooth. The Normals are all facing outside and I tried adding a weighted normal modifier, als well as recalculating the outside and merging the normals. Nothing worked and I'm slowly getting out of ideas. Does any one of you have an idea?

Update: The Shading issues seemed to be because of evee. I still got some issues when importing the model to unity, but more in the places where the topology is messy, so this should be better once I clean it up a little. Still don't have any idea, why smooth shading doesn't work. No smooth Shading

$\endgroup$
2
  • $\begingroup$ Could you highlight which area looks strange to you? If you mean that banding along the front beneath the cushions, that looks quite normal to me, assuming you're using Eevee. If that's the case you'll need to play with your shadow settings in order to smooth it out a little bit. I recommend adding samples in the Render settings, but also looking at the shadow settings of each of your lights. $\endgroup$
    – Onyx
    Feb 4 at 11:05
  • $\begingroup$ Thanks. in terms of the shading issues it really seems to be because of evee. Some parts still looks weird if i put the model into unity, but thats where the topology is messy, so that should be fixed once I clean it up. But I still don't have any idea, why smooth shading is not working $\endgroup$
    – Alex S.
    Feb 4 at 11:13

1 Answer 1

0
$\begingroup$

Two possible reasons here:

  1. Normal map is set to sRGB instead of non-color data:

enter image description here

  1. Custom normals option has been activated:

enter image description here

Clear custom split normals data in this case.

$\endgroup$
2
  • $\begingroup$ Thank you, much appreciated, but sadly both options didn't solve my problem 1. You were right, the normal map was set to SRGB, but sadly changing it didn't fix it 2. Nope, don't have custom normals activated $\endgroup$
    – Alex S.
    Feb 4 at 12:28
  • $\begingroup$ But it's definetly a problem with the normal map. Deactivating it made the shading work $\endgroup$
    – Alex S.
    Feb 4 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.