2
$\begingroup$

I am making an animation of three layers of tape.

However, as I move away from the camera, the layer that should be at the top becomes partially invisible. enter image description here enter image description here This happens in the view port as well.

Rendering Setting is Evee, since this is a test render, I set sampling to 8. (This also happened when I rendered at 500).

This is happening in both Blender 3.0.0/Blender 3.0.0 Alpha.

$\endgroup$

1 Answer 1

3
$\begingroup$

What happens here is a common problem called z-fighting. Basically, it's two surface that are so close together that Blender doesn't know which one he should put on top of the other. It usually is very noticeable when the distance between the surfaces and the camera is very big compared to the distance between the two surfaces, so the further your camera is, more difficult it becomes for Blender to "see" which surface is on top of each other.

To fix it you can use the camera clipping (as they say here) or you can modify your objects in a way that the two surfaces are not too close.

The second one may not be an option for you so here is how you can fix it with the clipping thing :

Select your camera and go to the Properties Panel > Object Data Properties > Lens :

enter image description here

There you have two settings Clip Start and (Clip) End. The Clip startis defaulted to something like 0.01m, increase it slightly to a few meters (around 5m looks like a good value for me). This will reduce the z-fighting artifacts.

Just be aware that Clip Start will make the objects close to the camera invisible so don't set it to high. Basically Clip Start value to 5m means that every object that are less than 5 meters away from the camera are going to be invisible. You just need to set it high enough to remove the z-fighting.

You have also Clipping options for the viewport :

Press N on the 3D viewport and go to the view tab :

enter image description here

This is what you see with the default 0.01 :

enter image description here

But if I set it just to 1 :

enter image description here

Just be aware that if you get close to the object with clipping set too high, you'll have this :

enter image description here

$\endgroup$
3
  • $\begingroup$ Mr.mqbaka Sorry for the late reply... And thank you very much for your kind answer! I am a beginner, but I understand perfectly. Of course I did some research on my own, but I could not reach "z-fighting" So very very helpful for me! The number 5.98 was also just perfect. There is no z-fighting at all. Let me say thank you so much again. $\endgroup$
    – Hana
    Feb 6 at 3:25
  • $\begingroup$ You're welcome. We do live in different timezones after all so late replays are not deadly sins :D $\endgroup$ Feb 7 at 5:40
  • 1
    $\begingroup$ I am very happy to receive such wonderful kindness from people from countries I have never visited. Thank you also for the Edit Sugget. I'm sure it will be a valuable post for a first-timer like me. $\endgroup$
    – Hana
    Feb 7 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.