3
$\begingroup$

I'm working with a 3rd-party payware Blender file and I set up a simple moving camera animation to test render time. The problem is that when I run the animation in the 3D viewport the animation runs at less than 4 fps, despite the fact that it's set for 30 fps. I've never seen this before.

I thought maybe the complexity of the scene was the issue, but the view is set to Viewport Shading and all scenery elements are hidden, but still the viewport animation crawls at less than 4 fps; this makes it impossible to preview the pacing of the camera movement. I'm baffled. Any suggestions? Thanks. Blender 3.0, Windows 11

enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ The fps given are: 1. an indicator for Blender when simulating physics and fluids how time passes in relation to frames, 2. the framerate with which movie files are created if you render animations directly as a moviefile instead of an image sequence and 3. at last the framerate with which animations are played in the viewport. But for number 3 the problem is, if for example simulations are not baked (or even if they are) or the scene contains many complex meshes, than realtime playback is often not possible. Blender "knows" it's playing to slow, therefore the lower framerate is shown in red. $\endgroup$ Commented Jan 31, 2022 at 19:10
  • 2
    $\begingroup$ I've run out of space in my last comment. Nevertheless, of course the ideal situation would be that the viewport playback is at the right speed of the set framerate and as the answer shows, there are ways to achieve it or at least come close. But sometimes you cannot simplify models, scenes etc. enough to reach that framerate. Especially high-res smoke simulations for example. In some YT tutorials the tutors even tell you, you should always make test renders with less samples or viewport renders and playback the rendered animation to check if the movements look right at the desired framerate. $\endgroup$ Commented Jan 31, 2022 at 19:15
  • $\begingroup$ I'm running into a similar problem, but with, seemingly, rather primitive meshes - linked buildings with no furniture. Vegetation is off. Simplify is all the way to 0. The viewport is moving fast, but the camera animation crawls with .4-.8 fps! Also, rendering takes 4 hours preparation time only, before rendering the first tile (which goes quite fast then). I understand, in the render all particles are on, but in solid mode viewport... I don't get it! Especially since viewport OUTSIDE camera is really fast! $\endgroup$ Commented Apr 11, 2022 at 16:19

1 Answer 1

4
$\begingroup$

Try enabling Simplify option in render tabs, with viewport max subdivision set to 0. One single complex character with subdivisions level 2 is enough to slow down viewport realtime rendering.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ That's it! Thank you! $\endgroup$
    – WilburPost
    Commented Jan 31, 2022 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .